Crashplan auf Windows Homeserver (WHS) installieren

Seit langem bin ich auf der Suche nach einer Off-Site Backup Lösung, die preislich noch im Rahmen ist, aber gleichzeitig auch relativ große Datenmengen erlaubt. Letzteres ist bei nahezu allen “einfachen” Diensten wie Dropbox, OneDrive, iCloud usw. nicht gegeben, da dort eher im Bereich GB bis wenige TB gearbeitet wird. Als Fotograf mit sehr vielen und leider auch sehr großen RAW Files stoße ich da relativ schnell an die Grenzen. Hinzu kommt die Einschränkung, dass ich meine Daten auf einem Windows Homeserver liegen habe, der auch gleichzeitig das zentrale Backup übernehmen soll. Mit Crashplan bin ich fündig geworden – es gibt einen “unlimit” Backup für 60€ im Jahr – und der Client läuft auch unter Windows Homeserver. Andere Anbieter blockieren sofort, wenn sie merken, dass der Client auf einer “Serverversion” von Windows läuft. Crashplan glücklicherweise nicht.

Zurück zum Thema. Ich hab den Client installiert und es passiert nichts. Der Dienst besteht aus zwei Teilen: einer Backup Engine und der Gui. Die Gui sagte mir einfach nur, dass sie die Backup Engine nicht finden könne. Ein Blick in den Dienste Manager von Windows zeigte mir, dass der Service auch nicht lief. Wenn man ihn starten wollte, kam nur die Meldung, dass der Dienst “gestartet und anschließend gleich wieder gestoppt/pausiert wurde. Keine weiteren Hinweise oder Logs. Nach etwas Recherche im Netz fand ich zumindest Hinweise, dass es wohl Probleme mit den Portbelegungen gibt – aber bei mir wollte ja der Dienst nicht mal starten. Die Lösung war dann doch etwas simpel: Der Client verbraucht per Default mittlerweile 1GB Ram – und das hat mein Acer Aspire easyStore H340 mit seinen 2GB Ram scheinbar nicht mehr übrig. Also editiert man in der Datei “c:\Programme\CrashPlan\CrashPlanService.ini” die Zeile mit den Java Virtual Machine Parameters:

von

-Xmx1024M

in

-Xmx512M

Und schon läuft der Service, sobald man ihn nochmal startet. Aber der Client wollte noch immer nicht – und da kam die eben genannte Port Problematik zum Vorschein. Um dies nachvollziehen zu können, ruft man die Command Shell von Windows auf und gibt da folgendes ein:

netstat -ona

Bildschirmfoto 2016-05-08 um 14.28.37 Kopie

Wie man sieht, lauscht die Backup Engine auf Port 4242, der Port im Client ist per Default jedoch 4243. Wenn man nun in der Datei “c:\Programme\CrashPlan\conf\ui.properties” die folgende Zeile editiert, läuft es:

#servicePort=4243


in

servicePort=4242

Abschließend startet man nun den Client und wird endlich von der Crashplan Oberfläche empfangen 😉

Published by

bytelude

Softwareentwickler, Technik Fanatiker, Apple Fan, Kinoliebhaber, Prokrastinations-Spezialist

Leave a Reply

Your email address will not be published.